Fixing ClassNotFoundException for TSMBcEngineDeployActions in BusinessConnect (BC) during application deployment.

Fixing ClassNotFoundException for TSMBcEngineDeployActions in BusinessConnect (BC) during application deployment.

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Article ID: KB0136794

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Updated On:

Products Versions
TIBCO BusinessConnect all versions

Description

Resolution:
Description:
============
When trying to deploy a BC application in ApplicationManagement, the following error is seen:

2010 Nov 11 13:05:55:170 GMT -4 Error [Administrator] AESDKJ-0000 [http-8080-Processor23]  com.tibco.wfc.util.ServletRuntimeException: com.tibco.ax.gui.bcwebadmin.deployment.TSMBcEngineDeployActions
    at com.tibco.administrator.consoles.deploymentconfiguration.DeployUndeployDialog.if(DeployUndeployDialog.java:599)
    at com.tibco.administrator.consoles.deploymentconfiguration.DeployUndeployDialog.access$700(DeployUndeployDialog.java:76)
[...]
Caused by: java.lang.ClassNotFoundException: com.tibco.ax.gui.bcwebadmin.deployment.TSMBcEngineDeployActions
    at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
    at java.security.AccessController.doPrivileged(Native Method)
[...]


Environment:
============
BusinessConnect all versions


Symptoms:
=========
When I try to deploy BC application in ApplicationManagement, the deployment is failing with java.lang.ClassNotFoundException: com.tibco.ax.gui.bcwebadmin.deployment.TSMBcEngineDeployActions

Cause:
======
The required war/jar/class files are unable to load during the admin/hawk start up.


Resolution:
===========
1. Please verify if the BC plugin or Protocol plugin (edi/rosettanet/soap/ebxml etc) war file is in &ltadmin_home>/&ltversion>/administrator-plugins, folder.

2/ If not available in administrator-plugins folder, then copy the bc war file (bcwebadmin.war) from the bc_home/&ltversion>/admin-plugins folder to the administrator-plugins folder, and protocol war file (bcediadmin.war/bcrnadmin.war/bcsoapadmin.war/bcebxmladmin.war etc) from bc-protocol-home/admin-plugins foder to administrator-plugins folder.

3/ Take a backup and remove the bc war file from the bc_home/&ltversion>/admin-plugins folder and/or protocol war file from bc-protocol-home/admin-plugins foder.

4/ Restart Admin & Hawk

5/ After restarting Hawk and Admin, you can copy the backup bcwar file to bc_home/&ltversion>/admin-plugins folder and/or protocol war file(s) to  bc-protocol-home/admin-plugins foder

6/ Again restart Admin & Hawk

Issue/Introduction

Fixing ClassNotFoundException for TSMBcEngineDeployActions in BusinessConnect (BC) during application deployment.