User is unable to login in to the iProcess Administration Console (iPAC) when password checking is enabled.

User is unable to login in to the iProcess Administration Console (iPAC) when password checking is enabled.

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Article ID: KB0137361

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Updated On:

Products Versions
TIBCO iProcess Engine (Oracle) All supported versions , for all iprocess variants
TIBCO iProcess Engine (DB2) All supported versions , for all iprocess variants
TIBCO iProcess Engine (SQL) All supported versions , for all iprocess variants

Description

Description:

Symptoms:

The user gets an error while logging in iPAC console when password check is enabled.
Errors:
"Unable to start admin login process"
"Incorrect password"

Entries observed in ipac.log file:

[INFO ] com.tibco.api.common.Utility startProcess() - Process name is ./authipaclogin and port is 49666

[ERROR] com.tibco.api.common.Utility startProcess() - Cannot run program "./authipaclogin": error=13, Permission denied

Cause:
Permissions are incorrect in authipaclogin and runcmd binaries

Environment

TIBCO iProcess Engine all supported versions on all supported Operating systems

Resolution

The authipaclogin is in $SWDIR/util

$ ll authipaclogin
-r-sr-s--- 1 root staffwar 44451 Nov 23  2023 authipaclogin
 
Check the file exists and with the correct permissions and ownership as above.

# Permission commands for: $SWDIR/util/authipaclogin
 
chown root:staffwar $SWDIR/util/authipaclogin
chmod 06550 $SWDIR/util/authipaclogin
 
There can also be issues with 'runcmd'
 
# Permission commands for: $SWDIR/util/runcmd
 
chown root:staffwar $SWDIR/util/runcmd
chmod 06550 $SWDIR/util/runcmd

Note: Replace staffwar with the group name you have in your iProcess environment.

Issue/Introduction

The user is unable to login in iPAC console when password checking is enabled.