Products | Versions |
---|---|
TIBCO Administrator | - |
Not Applicable | - |
Resolution:
Description:
============
While exporting applications using the AppMange in batch mode, the ear files are exported but not the deployment configuration files.
Environment:
===========
All supported operation systems.
Symptoms:
========
In the ApplicationManagement.log file, the following exception will be reported:
[com.tibco.administrator.command.tool.ApplicationManagement] AESDKJ-0000 [main] com.tibco.pof.entity.EntityStoreException:
at com.tibco.pof.entitystore.db.DBEntityStore.a(DBEntityStore.java:939)
at com.tibco.pof.entitystore.db.DBEntityStore.getEntityInputStreamHelper(DBEntityStore.java:1219)
at com.tibco.pof.entitystore.db.DBEntityStore.getEntityInputStreamByID(DBEntityStore.java:1189)
at com.tibco.pof.entitystore.AbstractEntityStore.getEntityInputStreamByURI(AbstractEntityStore.java:1038)
Caused by: com.tibco.runtime.pool.TimeoutException: Timeout getting connection for address com.tibco.runtime.pool.impl.ConnectionPoolImpl@
at com.tibco.runtime.pool.impl.ObjectCatcherImpl.checkForResults(ObjectCatcherImpl.java:68)
at com.tibco.runtime.pool.impl.ObjectCatcherImpl.waitForCompletion(ObjectCatcherImpl.java:85)
Cause:
=====
This error suggests that the AppManage is running out of Database (DB) connections.