book
Article ID: KB0070821
calendar_today
Updated On:
Description
After installing iProcess workspace (browser) on IIS, the client URL does not work.
Symptoms:
- Action Processor URL returns expected response
- No error entries are seen in APLog.log
- When accessing iProcess Workspace (browser) URL, the below error is seen -
Unable to establish a connection to the action processor
Verify the Action Processor is running and the configuration URL is correct
- Inspecting the network logs using browser dev tools, the action processor URL returns a 500 error code.
Cause:
The HTTP runtime rejects the initial validation as .NET framework 4.7 is used
Resolution
When using IIS 8.5 or 10 and configuring Action Processor with a .NET 4.0 App Pool, the below post-install step is required -
If you are hosting the .NET Action Processor in IIS 8.5 or 10, and you want the Action Processor to run in a .NET Framework 4.0 Application Pool, you must open the web.config file for the Action Processor’s web site, and uncomment the following line:
<!--httpRuntime requestValidationMode="2.0" /-->
This is required because .NET Framework 4.0 disables switching off validation of HTML input (that is, it causes the Validate=false setting in ActionProcessor.aspx to be disregarded).
Issue/Introduction
This article documents a cause of "Unable to establish a connection to the action processor " when the iProcess Workspace (browser) is hosted on IIS