How to migrate a Statistica concurrent install to a new server?

How to migrate a Statistica concurrent install to a new server?

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Article ID: KB0071433

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Updated On:

Products Versions
Spotfire Statistica 8.0 and above.

Description

With a network license, what are the steps to move the Statistica software to a new server?

Possible Causes:
  • Old server operating system is no longer supported
  • Upgrading to new server
  • Replacing old server 

 

Issue/Introduction

This article has the steps to move a Statistica concurrent install type to a new server. This does not apply to enterprise/server migrations.

Environment

Windows operating systems only. For Statistica 13.0 and above, Windows Server 2008 R2 (Windows 7) and above only.

Resolution

Note:   Only for CNET-type installations, i.e., any network install with a serial number that ends in CNETXX-X.
 

Scenario 1:  Application files and licensing service reside on the same server.  

1.  Install all Statistica components (application files, licensing service, and workstation installer files) on the new server

2.  Change the pointer license file information for each workstation/client to match the new server information (see How to point workstations to a different Statistica license server?)

3.  The move is now complete

 

Scenario 2:  Application files and licensing service reside on SEPARATE servers

If upgrading just the server where the licensing service is located, follow these steps:

1.  Install and select the "Custom" install option and just select the "License Manager Service":

Selecting only the license  service
2.  Click "Next"
3. Continue to complete the install
4. Once the new license service has completed the install, use the ClientSTAT.tmp file, located typically at C:\Program Files\TIBCO\Statistica\ or C:\Program Files (x86)\Statistica\FLEXlm\,  as the new pointer file for the workstation/clients.  See How to point workstations to a different Statistica license server?