Application reports: "Repository not found" upon starting even though the deployment is successful.

Application reports: "Repository not found" upon starting even though the deployment is successful.

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Article ID: KB0072711

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Updated On:

Products Versions
TIBCO Administrator -
Not Applicable -

Description

Description:

Deployment is successful, but application's repository is not created under the folder %TIBCO_HOME%\tra\domain\domainname\datafiles\applicationname_root . This may happens randomly and deployment of big .ear files is more likely to happen. 


Symptoms:
<-----------
2014 Oct 22 03:53:09:423 GMT +2 BW.Oracle-RMSServices-Oracle-RMSServices Error [BW-Core] BWENGINE-100037 Repository not found: C:/tibco/tra/domain/ESB-DEV-C15/datafiles/Oracle-RMSServices_root
Repository not found: C:/tibco/tra/domain/ESB-DEV-C15/datafiles/Oracle-RMSServices_root
at com.tibco.pe.core.RepoLoader.<init>(Unknown Source)
at com.tibco.pe.PEMain.a(Unknown Source)
at com.tibco.pe.PEMain.do(Unknown Source)
at com.tibco.pe.PEMain.a(Unknown Source)
at com.tibco.pe.PEMain.<init>(Unknown Source)
at com.tibco.pe.PEMain.main(Unknown Source)
----->
Cause:
During deployment, TRA hawk agent would create a .tmp folder (like "C:/tibco/tra/domain/ESB-DEV-C15/datafiles/Oracle-RMSServices_root.tmp"), and create all files for the application, then delete the older folder, and rename the .tmp folder to the application's repo folder. Some anti-virus software may think this behavior is suspicious and stop hawk agent from renaming the .tmp folder and delete this folder. 

Issue/Introduction

Application reports: "Repository not found" upon starting even though the deployment is successful.

Resolution

Users may can try below options:
  • Disable the anti-virus software during deployment
  • exclude folder %TIBCO_HOME%\tra\domain\domainname\datafiles\.
  •  Add the TRA hawk agent ($TIBCO_HOME/tra/domain/domainname/hawkagent_domainname.exe) to the white list of the anti-virus software and allow it to change .tmp folder to application's repo folder.
 Another possible reason is that some process may have been holding locks on the datafiles folder. Rebooting the machine and restarting the Hawk agent should resolve the issue.