Troubleshooting techniques for an L042 error when logging in to the TIBCO iProcess Workspace (Windows).

Troubleshooting techniques for an L042 error when logging in to the TIBCO iProcess Workspace (Windows).

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Article ID: KB0074830

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Updated On:

Products Versions
TIBCO iProcess Workspace (Windows) -
Not Applicable -

Description

Description:
This article is meant to assist in some of the more common reasons for an L042 error when logging into TIBCO iProcess Workspace (Windows) (iPWW),

Symptoms:
An L042 error is received when logging into iPWW.

Cause:
An L042 error is received when there has been some form of communication problem between iPWW and the iProcess Engine components.

Resolution

The following can be used to investigate the cause of an L042 error when logging into iPWW.

1). Ensure the TIBCO iProcess Engine (iPE) you are trying to login to is up and running. You can verify this by inspecting that all required processes are running and utilizing such tools as $SWDIR/util/swadm show_processes.

2) Verify that the registry key used for iPE is set up to connect to the correct machine name or IP address and RPC port. The following keys may contain the defined iPE engine entry.

For versions prior to 11.8:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Staffware plc\Staffware Client\Default\RPC Servers

HKEY_CURRENT_USER\Software\Staffware plc\Staffware Client\Default\RPC Servers

For versions 11.8 or higher:

HKEY_LOCAL_MACHINE\Software\TIBCO iProcess\TIBCO iProcess Workspace (Windows)\Default\RPC Servers

HKEY_CURRENT_USER\SOFTWARE\TIBCO iProcess\TIBCO iProcess Workspace (Windows)\Default\RPC Servers

If anything exists in HKCU for user(s), it will override what is put in HKLM.  Check both keys to ensure they are correct.  A key Data value will look like the following:

<Machine Name or IP Address>,<RPC Number>,<Password Dialog Display>,<iPE Connection Description>

3) Make sure the <Machine Name or IP Address> value in the registry key for the TIBCO iProcess Engine is not more than 30 characters or it will throw an L042 error even though the machine name is correct. If the machine name contains a fully qualified domain name that exceeds the 30 characters limitation, it is advisable to use the IP address of the machine hosting the TIBCO iProcess Workspace (Windows) or just the hostname.

4) If your key utilizes Machine Name, try to ping the iPE engine using the defined name and ensure it is reachable and resolves to the correct IP address of the iProcess Engine. Confirm that the RPC Number is correct for the iProcess Engine being contacted. Compare the RPC Number in the registry key with the RPC number on line 11 of the $SWDIR/swdefs file.

5). To properly communicate with iPE, the portmapper will need to be running. For Windows, this is the "NobleNet Portmapper for TCP" service on the iPE Engine machine and for Unix this is rpcbind. Test that communication to the portmapper and the configured TCP port can be established properly.

First, test that port 111 can be reached properly using an application such as telnet. An example command:
telnet <MachineName> 111

If telnet is not available, you can utilize any tool available to you. Here is another example using a PowerShell script:

Create a file called 'testconn.ps1' and paste the following into it using a text editor:

***

[CmdletBinding()]
Param(
 [Parameter(Mandatory=$True,Position=1)]
  [string]$ip,

  [Parameter(Mandatory=$True,Position=2)]
  [int]$port
)

$connection = New-Object System.Net.Sockets.TcpClient($ip, $port)
if ($connection.Connected) {
   Return "Connection Success"
}
else {
   Return "Connection Failed"
}
***

Save the changes and test calling port 111 in a Windows PowerShell session using the following syntax:
.\testconn.ps1 <MachineName> 111


If you cannot contact to port 111, check that the portmapper processes are up and running. If they are, contact your system administrator to ensure port 111 is not blocked from the client machine to the iPE. A connection must also be made from the client machine to the TCP port assigned to the iPE RPC Number. On a Unix machine, issue rpcinfo -p and match the RPC number defined on line 11 of $SWDIR/swdefs to the TCP port number you need to test. On a Windows machine, navigate to C:\Program Files (x86)\NobleNet Portmapper for TCP and run rpcinfo.exe. Once opened, choose Info > Portmap Dump. Match the RPC number defined on line 11 of $SWDIR/swdefs to the TCP port number you need to test. If you cannot contact the RPC TCP port number, verify that there is not a firewall blocking the port in question. If you need to assign a particular TCP port range to use for RPC communication, you can do so by following the steps outlined in "Using the TIBCO iProcess Engine in a Firewalled Environment" located here:

https://docs.tibco.com/pub/ipe-db2/11.8.0/doc/html/tib_ipe_architecture_guide/network.14.1.htm#1034163
 

Issue/Introduction

Troubleshooting techniques for an L042 error when logging in to the TIBCO iProcess Workspace (Windows).

Additional Information

https://docs.tibco.com/pub/ipe-db2/11.8.0/doc/html/tib_ipe_architecture_guide/network.14.1.htm#1034163