Software becomes uninstalled in the Admin GUI and "Can not register software" appears in tsm.log.

Software becomes uninstalled in the Admin GUI and "Can not register software" appears in tsm.log.

book

Article ID: KB0074957

calendar_today

Updated On:

Products Versions
TIBCO Runtime Agent (TRA) -
Not Applicable -

Description

Resolution:
Description:
============
Installed software does not show in the Administrator GUI or changed to "Uninstalled".

After set "-tsm_traceLevel" to -1 in hawkagent.cfg and restart the Hawk agent, we can see the Hawk agent does detect all installed components in the tsm.log, but there is an error like the following:

<-------- tsm.log -------
2013 Feb 07 09:27:35:031 GMT 11 tsm Error [] [TRA-000000] Can not register software because can not find machine oncillad in the domain.
------>


Environment:
===========
TIBCO Administrator 5.x.x
TIBCO Runtime Agent 5.x.x
OS: All

Symptoms:
============
Installed software doesn't show in the Administrator GUI or become Uninstalled.

Cause:
============
The machine name might be different from the one showed in the Administrator GUI.
 

Resolution

1). Verify the machine name is the same as showed the Administrator GUI.
2). Check $TIBCO_HOME/tra/domain/domainname/hawkagent.cfg file and make sure option "-agent_name" and "-machine_name" reflects the hostname.

Please contact tibco support if further help is needed. 

Issue/Introduction

Software becomes uninstalled in the Admin GUI and "Can not register software" appears in tsm.log.