Node Manager fails to start the Service Instance if the Service Account does not have the Local Admin rights.

Node Manager fails to start the Service Instance if the Service Account does not have the Local Admin rights.

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Article ID: KB0075675

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Updated On:

Products Versions
Spotfire Server 7.5 and higher

Description

Description:
Node Manager fails to start the Service Instance if the Service Account does not have Local Admin rights.
 
Symptoms:
Service Instance fails to start and the following error is reported in the logs.
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Failed to start worker. System.Security.Cryptography.CryptographicException: Access is denied. at System.Security.Cryptography.X509Certificates.X509Store.Open(OpenFlags flags) at Spotfire.Dxp.Worker.Services.Web.Utilities.TrustCertificateHandler.SpotfireCertificate.ExecuteOnStore
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Cause:
Node Manager does not have Local Admin rights and should have this to be able to register an SSL port on Windows.

Issue/Introduction

Node Manager fails to start the Service Instance if the Service Account does not have Local Admin rights.

Environment

All Supported Operating Systems

Resolution

Make sure that the Custom Service Account used for the Node Manager is a member of the Local Administrator group.
 
From the Manual:
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 Important: If you change the node manager service account, make sure that the account is a local administrator and that it has read and write access to the node manager installation directory and subdirectories.
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Additional Information

https://docs.tibco.com/pub/spotfire_server/10.3.4/doc/html/TIB_sfire_server_tsas_admin_help/GUID-3237F847-3135-4F10-8284-1D66F6DEC36E.html