Products | Versions |
---|---|
Spotfire Statistica | 13.0 and higher |
Description
After opening Statistica on the workstation and trying to connect to the Server by going on Server tab and clicking Login the error message appears: "No response from Server at the specified URL:XXXXXXX".
Cause
1. Wrong login information has been used;
2. Workstation System DSN has not been configured;
3. There is a configuration discrepancy of the Server settings between Server and the workstation (e.g. server and workstation are on different domains).
SOLUTION 1
Please open the Registry Editor (Start menu>regedit) and navigate to HKEY_CURRENT_USER\SOFTWARE\Classes\STATISTICA.Application, and check if there is a "wsid" subkey present. If yes, delete that entry, delete the entire wsid entry, not just the value.
This will clear the connection session cookie reference and allow us to perform a fresh connection.
Restart Statistica and try to reconnect with valid credentials.
SOLUTION 2
Open System Data Sources (ODBC) (Start menu>Control Panel>Administrativetools>Data Sources (ODBC)), then choose System DNS tab. Here you should see System Data Source with Server name that should correspond to the Server you are trying to connect from the workstation. Please click Configure, and go through the wizard that will allow you to test data connection with a server.
Please restart Statistica and try to reconnect.
SOLUTION 3
Please make sure that the Workstation Server settings (Enterprise manage>System Options>Statistica Server) correspond to:
Port: 8082, Site: WebSTATISTICA, Extensions: ISAPI/StaISAPI.dll
The fully qualified name would need to be specified for the server.
Please restart Statistica and try to reconnect
For more information regarding the SOLUTION 3 please consult this article: https://support.tibco.com/s/article/Changing-TCP-IP-port-used-by-WebSTATISTICA-service