Analysis based on data connection returned the following error for some Web Player users: "The library entry may have been removed or you may not have the right to access it."

Analysis based on data connection returned the following error for some Web Player users: "The library entry may have been removed or you may not have the right to access it."

book

Article ID: KB0082585

calendar_today

Updated On:

Products Versions
Spotfire Web Player All Versions

Description

Web Player user received the error "The library entry may have been removed or you may not have the right to access it.", when trying to access an analysis based on a data connection.

In this scenario, the analysis files uses external data connections saved to the Spotfire library. The folder where the data connection and the analysis file resides are set with "Access" permissions for the "Everyone" group, or the group where the Web Player consumer belongs. Analyst users, those who create the report using the Spotfire Analyst/Professional client, do not have this issue. Only consumer users, those who access Spotfire through the Web Player, see this issue.

Symptoms:

When Web Player users access the analysis file from the browser, they are not able to open the report. In a pop up dialog and in the Web Player logs, the following error message will be reported.

ERROR 2015-12-01 16:13:27,902 [pqqhoyftufuk3qhmszfnh0j6, 6492, WorkThread 412, user@company.com WAT 103] Spotfire.Dxp.Framework.ApplicationModel.NotificationService - Data Connection Library Access
The library entry '/Data Connections/My Data Connection' could not be accessed. The data connection 'My Data Connection' may be out of date.
The library entry may have been removed or you may not have the right to access it.

Cause:
The "Everyone" group, or the group where the Web Player consumer belongs only has "Access" permissions to the folder where the data connector object resides.

Issue/Introduction

Analysis based on data connection returned the following error for some Web Player users: "The library entry may have been removed or you may not have the right to access it."

Resolution

To resolve, give the users "Browse+Access" permissions for the folder where the connector resides:
  1. In the Administration Manager: For the consumer (Spotfire Web Player) user's group, verify the group has licenses to access the data connector.
    • Tools > Administration Manager > Groups and Licenses > select the consumer (Spotfire Web Player) user's group > Licenses tab > TIBCO Spotfire Connectors
  2. In the Library Administrator: Give "Browse+Access" permissions for the folder where the connector resides to the consumer (Spotfire Web Player) user's group.


Optional:

To hide the connector and not provide Browse permissions to the connector for the consumer users, you can put the connector one level down, so the users cannot browse to the connector. For example:
  • Library
    • Folder
      • Level 1 (No Access )
        •  Level 2 ("Access+Browse" to the folder only)
          •  Data Connection