Products | Versions |
---|---|
Spotfire Web Player | 7.0 to 7.8 |
Symptoms:
1. When accessing TIBCO Spotfire Web Player or the TIBCO Spotfire Professional Client, you receive an error message like the following:
------------------------------
Error accessing preference storage.
ActiveX: True, Beta: False, Browser: IE, ClrVersion: 3.5.30729, Cookies: True, EcmaScriptVersion: 3.0, Frames:
True, Id: ie7, InputType: keyboard, IsMobileDevice: False, JavaApplets: True, JScriptVersion: 5.7,
MaximumHrefLength: 10000, MaximumRenderedPageSize: 300000, MobileDeviceManufacturer: Unknown, MobileDeviceModel:
Unknown, MSDomVersion: 7.0, Platform: WinNT, PreferredImageMime: image/gif, PreferredRenderingMime: text/html,
PreferredRenderingType: html32, SupportsUncheck: True, SupportsXmlHttp: True, Tables: True, Type: IE7,
UseOptimizedCacheKey: True, VBScript: True, Version: 7.0, W3CDomVersion: 1.0, Win32: True
------------------------------
2. On the Spotfire Server, log [server install dir]\tomcat\logs\server.log contains errors like the following
------------------------------------
ORA-00600: internal error code, arguments: [qkacon:FJswrwo], [3], [], [], [], [], [], []
------------------------------------
Cause:
This issue is caused by a bug in Oracle 10.2.0.2 through 10.2.0.4, related to CONNECT BY queries, that can cause problems with loading preferences.