How to recover from the error - "Failed to queue task on EMS server"

How to recover from the error - "Failed to queue task on EMS server"

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Article ID: KB0083966

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Updated On:

Products Versions
TIBCO BPM Enterprise (formerly TIBCO ActiveMatrix BPM) 2.2.0, 3.0.0, 3.1.0, 4.0.0, 4.1.0

Description

Symptoms:
- The deployment, if performed from TIBCO Business Studio - BPM Edition, never completes. 
- TIBCO ActiveMatrix Administrator (AMX Admin) reports the application status as "Stopped". 
- The error - "Error Queuing Task (Deploy with Start)" - is seen in the application's action history.

Cause: 
This can occur if the TIBCO Enterprise Messaging Server was restarted after TIBCO ActiveMatrix BPM was already running that led to a loss in connection.

Issue/Introduction

The error "Failed to queue task on EMS server" maybe encountered during deployment of a BPM application.

Environment

OS: All Supported Operating System

Resolution

From AMX Administrator, Admin Configuration > Admin Server > Reconnect to EMS Server.