Unable to remove a Trading Partner's unused or expired certificates in BusinessConnect.

Unable to remove a Trading Partner's unused or expired certificates in BusinessConnect.

book

Article ID: KB0084043

calendar_today

Updated On:

Products Versions
TIBCO BusinessConnect -

Description

When trying to delete a certificate associated with a specific trading partner, the BusinessConnect Administrator throws this error:

"Failed to remove credential. KeyStoreItem: <CertificateName>, cannot be deleted as it is currently bound to one or more secured Transports, or used by Document Security settings in one or more Business Agreements".

Environment

BC Version 6.2.x Applicable to all Environments.

Resolution

Cause:

The trading partner certificate is stored in a hidden place in the Business Agreement for the Trading partner that is not exposed via the Administrator GUI. In some cases, we found that the Business Agreement may retain certificate information even if it is not shown in the BusinessAgreement itself. 

Resolution:

To remove the unused or expired certificate of a partner:

1. Take down the BusinessAgreement configuration completely, via screenshots or notes.

2. Delete the Business Agreement entirely. 

2. Then, try to remove the unused or expired certificate from the Trading Partner's Credentials tab.

3. Recreate the Business Agreement.

 

Issue/Introduction

A Trading Partner's unused of expired certificates can not be remove through the Administrator for BusinessConnect