Products | Versions |
---|---|
TIBCO BusinessConnect | - |
Not Applicable | - |
Resolution:
Description:
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BusinessConnect (BC) fails to pull files from the SSHFTP server after getting a 550 signal. Previously, it worked perfectly while getting a 220 ok signal.
Environment:
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Applicable to all the environments.
Symptoms:
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BC stops pulling files from the SSHFTP server and continually gets a 550 signal from the server. A 550 signal means either the files are non-existent or access to that file is denied.
Cause:
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There are situations in which the SSH tunnel gets corrupted. BC sees the tunnel and thinks its a legitimate tunnel and tries to pull the files even though the tunnel has been corrupted. So BC will get a 550 signal back and will fail to get the files from this point on.
Resolution:
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The resolution for this condition is to break the corrupted tunnel and create a new tunnel instance. This can be done by setting a timeout for the tunnel in the in-active state. Log into the admin GUI, and navigate to BUSINESS CONNECT -> SYSTEM SETTINGS ->INSTALLED PROTOCOLS -> BC SERVER and set the "bc.sshftp.cache.tunnel " property to a value in minutes. This would create a new instance of the tunnel after the timeout.