Unable to start the setup.exe for installation on iProcess Engine with Oracle database/client.Error stating Unable to open file: fil.dll rc =-1

Unable to start the setup.exe for installation on iProcess Engine with Oracle database/client.Error stating Unable to open file: fil.dll rc =-1

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Article ID: KB0084974

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Updated On:

Products Versions
TIBCO iProcess Engine (Oracle) -
Not Applicable -

Description

Resolution:
Description:
============
Unable to start the setup.exe for installation of TIBCO iProcess Engine (iPE) with Oracle database/client. Error stating Unable to open file: fil.dll rc =-1

Environment:
============
TIBCO iProcess Engine running on Windows
Oracle 10G/11G release


Symptoms:
=========
Unable to start the setup.exe/swinstall for installation of iPE with Oracle database/client
Error stating Unable to open file: fil.dll rc =-1

Cause:
======
When the Oracle client or database was installed the Oracle MTS component was not installed.


Resolution:
===========
When the Oracle client or database is installed, the Oracle MTS component must also be installed by selecting it through a Custom Installation, as it is not installed by default on Oracle 10g version.  Oracle 9i version does install this component by default.

Issue/Introduction

Unable to start the setup.exe for installation on iProcess Engine with Oracle database/client.Error stating Unable to open file: fil.dll rc =-1