When doing a BusinessConnect upgrade, the Admininistrator can not import the .csx file.The Admininstrator just hangs.What can be done to alleviate this issue?

When doing a BusinessConnect upgrade, the Admininistrator can not import the .csx file.The Admininstrator just hangs.What can be done to alleviate this issue?

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Article ID: KB0085145

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Resolution:
Description:
============
When  performing a BusinessConnect upgrade or importing a .csx file into a new environment, the Administrator "hangs" and does not complete the import.


Environment:
==========
TIBCO BusinessConnect Protocol 5.X.X all versions

Cause:
==========
The standard Administrator .tra file setting is not large enough to accommodate the amount of memory needed by the BusinessConnect Admininstrator plugin to import the .csx file.

Resolution:
=========
Modify this parameter in the $TIBCO_HOME/administrator/domain/&ltdomain name>/bin/tibcoadmin_&ltdomain name>.tra file:

java.heap.size.max 512m

to this:

java.heap.size.max 1024m

This will increase the amount of memory that the Administrator can use during normal operation.  Stop and restart the Administrator before trying another import.

NOTE: If you are running the Admininstrator as a service on Windows, you will have to modify this parameter using regedit.  The value to modify is:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TIBCOAdmin-&ltdomain name>\Parameters\java.heap.size.max

Stop and restart the service after making the modification.

Issue/Introduction

When doing a BusinessConnect upgrade, the Admininistrator can not import the .csx file.The Admininstrator just hangs.What can be done to alleviate this issue?