Products | Versions |
---|---|
TIBCO BusinessConnect | - |
Not Applicable | - |
Resolution:
Description:
============
When performing a BusinessConnect upgrade or importing a .csx file into a new environment, the Administrator "hangs" and does not complete the import.
Environment:
==========
TIBCO BusinessConnect Protocol 5.X.X all versions
Cause:
==========
The standard Administrator .tra file setting is not large enough to accommodate the amount of memory needed by the BusinessConnect Admininstrator plugin to import the .csx file.
Resolution:
=========
Modify this parameter in the $TIBCO_HOME/administrator/domain/<domain name>/bin/tibcoadmin_<domain name>.tra file:
java.heap.size.max 512m
to this:
java.heap.size.max 1024m
This will increase the amount of memory that the Administrator can use during normal operation. Stop and restart the Administrator before trying another import.
NOTE: If you are running the Admininstrator as a service on Windows, you will have to modify this parameter using regedit. The value to modify is:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TIBCOAdmin-<domain name>\Parameters\java.heap.size.max
Stop and restart the service after making the modification.