Products | Versions |
---|---|
TIBCO ActiveMatrix Policy Agent | - |
Not Applicable | - |
Resolution:
How to increase the HTTP timeout value in Proxy Agent?
Environment
==========
TIBCO Product name and version: TIBCO ActiveMatrix Policy Manager 3.x
Operating System(s): All Operating Systems
Symptoms
========
The following error is thrown with the default timeout value (60 seconds) in the event the service invocation takes a longer time:
Caused by: com.amberpoint.protocol.TransportException: timeout while receiving a message: Read timed out before the status-line was seen
Cause
=====
The default value of the HTTP timeout is set to 60 seconds so if you access a slow web service, you may see the error indicated above.
Resolution
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You will need to increase the value of following Java property in startProxyAgent.tra (under $TIBCO_HOME/policyagent/instances/agent-<port#>/bin directory).
java.property.com.tibco.protocol.http.client.connection.timeout
This timeout is configured at the HTTP level. The default value of this parameter is 60 seconds. Note: You will need to restart Proxy Agent after making this change.