Products | Versions |
---|---|
TIBCO Runtime Agent (TRA) | - |
Not Applicable | - |
Resolution:
Description:
============
How to overcome the following exception while doing TIBCO Administrator deployments and AppManage exports.
Caused by: com.tibco.runtime.pool.AllocationException: Connect failed to address: Pool:max=5: com.tibco.runtime.pool.TimeoutException: Timeout getting connection for address Pool
Environment:
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o All supported Operating Systems of TIBCO Administrator
o All Admin versions
Cause:
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This issue generally happens when the Admin, AppManage runs out of database connections.
Resolution:
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Increase the database connections by running the domainutility to a higher value based on the number of applications deployed. An approximate max value would be equal to the number of applications in the domain.
You need to run the domainutility on all the machines in the domain to change the db connections.