Administrator freezes up when deploying a new EAR file (white screen).

Administrator freezes up when deploying a new EAR file (white screen).

book

Article ID: KB0085860

calendar_today

Updated On:

Products Versions
TIBCO Administrator -
Not Applicable -

Description

Resolution:
Description:
============
Error in the Administrator Log:

2013 Aug 23 14:27:35:024 GMT -4 Error [Administrator] AESDKJ-0000 [http-28080-Processor41]  java.lang.IllegalArgumentException: Not a directory: /tmp/tibco_TIBUAT_Administrator_tt0vltam01editi_tibco
    at com.oreilly.servlet.MultipartRequest.<init>(MultipartRequest.java:211)
    at com.oreilly.servlet.MultipartRequest.<init>(MultipartRequest.java:148)
    at com.tibco.wfc.util.OreillyParameterParser.init(OreillyParameterParser.java:41)
    at com.tibco.wfc.util.ServletUtils.getParameterParser(ServletUtils.java:23)
    at com.tibco.wfc.FrameManager.if(FrameManager.java:306)
    at com.tibco.wfc.FrameManager.service(FrameManager.java:129)
    at com.tibco.administrator.AdministratorServlet.service(AdministratorServlet.java:957)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
    at org.apache.catalina.servlets.InvokerServlet.serveRequest(InvokerServlet.java:420)
    at org.apache.catalina.servlets.InvokerServlet.doPost(InvokerServlet.java:170)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:647)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
    at com.tibco.administrator.AdministratorServletFilter.doFilter(AdministratorServletFilter.java:52)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
    at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:581)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:879)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
    at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
    at java.lang.Thread.run(Thread.java:662)

Environment:
===========
TIBCO Administrator 5.x.x
TIBCO Runtime Agent 5.x.x
OS : RHEL 5.x

Symptoms:
========
During deployment of the EAR file, deployment fails or freezes up the Admin UI.

Cause:
=====

There is an issue with the /tmp folder. It might be full as the user deploys applications.

Resolution:

==========

1). Stop Admin, Hawk and all other TIBCO process.

2). Backup and clean the temporary directory by removing the directories that start with tibco_<Domain Name>_*

3). Restart the Admin, Hawk and applications.

If the issue continues, try to define a custom /tmp directory using the parameter

"java.property.java.io.tmpdir" in the tibcoadmin_<Domain Name>.tra

and

hawkagent_<Domain Name>.tra.

A best practice is to configure unique temporary directories for each domain. To configure a separate temp storage for Appmanage, hawkagent & Administrator,  add the following property:
            
java.property.java.io.tmpdir=<new_tmp_dir>
    - For Hawk:  to hawkagent_<domain_name>.tra
    - For Administrator: to tibcoadmin_<domain_name>.tra
    - For AppManage: to AppManage.tra (when the deployment is done using AppManage)
    - Create <new_tmp_dir>
    - Restart domain Hawk Agent and Administrator.

Be sure to check the <new_tmp_dir> folder size regularly, making sure they have  plenty of space for temporary files. Configuring a dedicated temp directory has the advantage of a reduced risk of accidental corruption by a user or some automated utility cleaning up the temporary files while Admin/hawk/AppManage are running. Never clean up the temporary files while those processes are running.

Issue/Introduction

Administrator freezes up when deploying a new EAR file (white screen).