BusinessConnect will not start after deployment in Single Server mode.The error message, "Too many open files",is dislayed.

BusinessConnect will not start after deployment in Single Server mode.The error message, "Too many open files",is dislayed.

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Article ID: KB0086030

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Resolution:
Description
==========
BusinessConnect does not start after deployment in Single Server mode. In the BusinessConnect_SingleServer.log file, the following error is seen:

Caused by: java.io.FileNotFoundException: /seamnt/prd101/tibco/tra/domain/domain_1/datafiles/BusinessConnect_root/Gateway/BMH/miscmsg-bmh-cmq-config.rvtransport (Too many open files)

Enviornments
============
UNIX/ LINUX/ AIX

Cause
=========
In Unix/Linux/AIX environments, there is a ‘ulimit’ setting that controls the resources available to a process that is started by the shell, on systems that allow such control.   The default number of open files setting may be set too low.  If this value is set too low and BusinessConnect needs to open a large number of files for a large activity, this number value can be exceeded.  Thus, the system is no longer able to open files, and  ‘Too many open files’ error is displayed.

Resolution
=========
Consult with your operating system administrator to raise the ulimit value for the account that BusinessConnect operates under.  A value of 4096 is the minimum value recommended.

Issue/Introduction

BusinessConnect will not start after deployment in Single Server mode.The error message, "Too many open files",is dislayed.