(TIBCO Collaborative Information Manager) CIM startup error as javax.naming.CommunicationException

(TIBCO Collaborative Information Manager) CIM startup error as javax.naming.CommunicationException

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Article ID: KB0086236

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Updated On:

Products Versions
TIBCO Collaborative Information Manager -
Not Applicable -

Description

Resolution:
Environment:

TIBCO Product name and version: TIBCO Collaborative Information Manager 8.0.0
Operating System(s): All Operating Systems

Symptoms:

The following exception will be thrown when starting jboss:

javax.naming.CommunicationException: Could not obtain connection to any of these urls: localhost:1099 and discovery failed with error: javax.naming.CommunicationException: Receive timed out [Root exception is java.net.SocketTimeoutException: Receive timed out] [Root exception is javax.naming.CommunicationException: Failed to connect to server localhost/127.0.0.1:1099 [Root exception is javax.naming.ServiceUnavailableException: Failed to connect to server localhost/127.0.0.1:1099

Cause:

The problem is because when you start jboss from a command prompt, you put –b &ltmachine hostname> rather than –b 0.0.0.0.

Resolution:

Start jboss with –b 0.0.0.0.

JBoss starting from version4.2 is binding by default only to localhost. If you want that jboss binds to all ip addresses in your machine, you need to use –b 0.0.0.0 option.


Attachments:
None

References:

None

Issue/Introduction

(TIBCO Collaborative Information Manager) CIM startup error as javax.naming.CommunicationException