BusinessConnect appears to continue to use an old expired certificate even after adding a new certificate to the Certificate store.

BusinessConnect appears to continue to use an old expired certificate even after adding a new certificate to the Certificate store.

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Article ID: KB0086333

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Resolution:
Description
===========
BusinessConnect continues to use an expired server identity even after adding a new identity to the Certificate Store when using the HTTP/S protocol for inbound transactions.

Environment
===========
All

Versions
========
All BC versions.

Cause
======
The BC Server identity is not upgraded automatically when a new server identity is added to the Certificate Store.  The BusinessConnect DMZ or Single Server engine must be redeployed when a new server identity is added.  This is for inbound HTTP/S transactions.

Solution
=========

After changing the identity, make sure that you have selected the newly added identity entry during the deployment.

Steps to select/change the BC Server identity:

1). Go to Application Management -> BusinessConnect -> Configuration-&gtHTTPS

2). Select new certificate name from drop –down list for 'Host Identity for HTTPS Server' and Save it  

3). Redeploy the application and restart it.  The new certificate will take effect.

Issue/Introduction

BusinessConnect appears to continue to use an old expired certificate even after adding a new certificate to the Certificate store.