When workitem locking is enabled if a workitem is cancelled after opening it, the workitem gets locked.

When workitem locking is enabled if a workitem is cancelled after opening it, the workitem gets locked.

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Article ID: KB0086381

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Updated On:

Products Versions
TIBCO Collaborative Information Manager -
Not Applicable -

Description

Resolution:
When workitem locking is enabled if a workitem is cancelled after opening it, the workitem gets locked.

Environment:
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TIBCO Product name and version: TIBCO Collaborative Information Manager 7.2.X and 8.0.0
Operating System(s): All Operating Systems

Symptoms:
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With TIBCO Collaborative Information Manager(CIM), when workitem locking is enabled if a workitem is cancelled after opening it, the workitem gets locked and the user has to explicitly do a release lock to release the workitem lock.

Cause:
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This happens when the "com.tibco.cim.workitem.lock.autolock" property in the ConfigValues.xml is set to "true".

Resolution:
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To resolve this issue, please try the following steps:

1. Stop the application server.
2. Set the "com.tibco.cim.workitem.lock.autolock" property in the ConfigValues.xml to "false".
3. Restart the server.


Attachments:
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None.

References:
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None

Issue/Introduction

When workitem locking is enabled if a workitem is cancelled after opening it, the workitem gets locked.