Error, "Unable to find ticket file tibrv.tkt in PATH" occurs while running TIBCO ActiveMatrix® Adapter for Files (Unix/Win).

Error, "Unable to find ticket file tibrv.tkt in PATH" occurs while running TIBCO ActiveMatrix® Adapter for Files (Unix/Win).

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Article ID: KB0086558

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks Plug-in for Files for Unix and Windows -
Not Applicable -

Description

Description:
This error occurs while running TIBCO ActiveMatrix® Adapter for Files (Unix/Win). A directory listing of the bin directory of the TIBCO Rendezvous® installation path does not show the tibrv.tkt file.
Symptoms:
TIBCO ActiveMatrix® Adapter for Files (Unix/Win) reports, "Unable to find ticket file tibrv.tkt in PATH" error while running.
Cause:
TIBCO Rendezvous® fails to validate the license file.

Resolution

If you are separately installing TIBCO Rendezvous® (RV), RV provides the  tibrv.tkt file if you are entitled to a permanent license. Otherwise, a tibrv.tkt file comes with TIBCO Runtime Agent™ (TRA) installer in the <TIBCO/RV_HOME>/bin  folder.

1). If the permanent license for TIBRV is available, then the tibrv.tkt can be used as a permanent solution.

2).If you are not entitled to a permanent license, you could rename the file  tibrvtkt.smp, which is located under <TIBCO/RV_HOME>/bin  to tibrv.tkt. This file contains a 60 minute temporary ticket for the Rendezvous product. You can create a new text file (tibrv.tkt) in the bin directory of the RV installation and paste the contents of tbrvtkt.smp into it.

Issue/Introduction

Error, "Unable to find ticket file tibrv.tkt in PATH" occurs while running TIBCO ActiveMatrix® Adapter for Files (Unix/Win).