Products | Versions |
---|---|
TIBCO ActiveMatrix BusinessWorks | - |
Not Applicable | - |
Resolution:
Description:
==========
A processes (contain timer starter) which contains a “Critical Section” us not visible through Administrator after the process starts up and is not being processed as expected.
Environment:
==========
TIBCO ActiveMatrix BusinessWorks / All
Cause:
==========
Customer uses Critical Section in a Group across multiple groups. In the BW document the description for using “Multiple Groups” follows:
---------------------------------------------
When the process instances are executed across multiple engines, the process engines must be configured to use a database for storage, and a database transaction is performed to ensure that only one process instance is executing the critical section group at any given time.
-------------------------------------------------
Customer has set the checkpoint data repository to “Local File” which causes this issue.
Resolution:
==========
Changing the checkpoint repository to database fixes the issue.