Products | Versions |
---|---|
TIBCO BusinessEvents Enterprise Edition | - |
Not Applicable | - |
Resolution:
Cause:
------
The issue is due to a defect in TIBCO EMS Server (64 bit release). Mostly the EMS Crash occurs in TIBCO EMS Server version 4.4.2 (64 bit server).
The issue where the BE engine hangs is caused because of specifying a null or empty destination (Queue/Topic name) in BE channel.
Product and OS Versions
------------------------
OS : Solaris 10
TIBCO Products: EMS 4.4.2, BE 2.x, BE 3.0 and BE 3.0.1
Solution
--------
Both the above issues should be solved if you make sure that you are not using a null or empty destination in your BE Channels. From BE 3.0.1 HF1 onwards, you should see a warning thrown in your engine logs on startup.
Optionally, you can consider upgrading to EMS 4.4.3 (64 bit) which should help in avoiding the EMS server crash issue.