“Unable to find the static stop method on the start class WRAPPER - Clear the exception raised by not finding static stop method inside main class” and “ServiceException” during installation.

“Unable to find the static stop method on the start class WRAPPER - Clear the exception raised by not finding static stop method inside main class” and “ServiceException” during installation.

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Article ID: KB0087521

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
============
Studio-tools --debug -help exits without showing TIBCO BusinessEvents version information and throws the errors: “Unable to find the static stop method on the start class WRAPPER - Clear the exception raised by not finding static stop method inside main class” and “ServiceException” during installation.

Environment:
============
TIBCO BusinessEvents  4.0.2
Linux Operating Systems

Symptoms:
============
When the command “Studio-tools  --debug -help” is run, the BusinessEvents version does not appear and it exits after the following output.

./studio-tools --debug -help

displays debug info only till

........
before CreateAppArgs
before CreateAppObjects
Unable to find the static stop method on the start class WRAPPER - Clear the exception raised by not finding static stop method inside main class after CreateAppObjects WRAPPER - About to call the start method on the start class

Also the following error was seen in 64bit BusinessEvents 4.0.0 installation logs:

ServiceException: (error code = 200; message = "null connDef"; severity = 0; exception = [java.lang.IllegalArgumentException: null connDef])
    at com.installshield.wizard.service.LocalImplementorProxy.invoke(Unknown Source)  

Cause:
============
The cause of this could be due to one of the following.

Check Install and hotfix install logs.

Try a fresh install of BusinessEvents 4.0.0 in a new TIBCO Home.

Studio and therefore studio-tools have a dependency on Operating System bit size. If 64-bit Linux is being run, it is advised to use 64-bit BusinessEvents and not the 32-bit version of BusinessEvents.  

Run the following command if on a Linux machine: uname –a

and check the size of the file descriptors .

Check if the issue is reproducible on another machine.

Ensure that permissions are checked and root user is being used.


Resolution:
============
The ServiceException error was caused by a corrupted database (InstallShield HSQL database used by the installer for non TIBCO assemblies) and resolved after removing the InstallShield database before installing the product. To do that, remove these files:

        ++++++++
        user.home/InstallShield/Universal/TIBCO/Gen1/_vpddb/vpd.*
        ++++++++

The directory "InstallShield" can be found in the home directory of the user that installs the products.

Move the corrupted InstallShield database and rename the directory temporarily.

Increase the value of the file descriptor to “ulimit -60000” (as an example) if value is too small.

Attempt another installation of BusinessEvents4.0.0 plus add on’s followed by BusinessEvents 4.0.2 .

Move the database back after the install.

Run studio –clean –initialize command.

Issue/Introduction

“Unable to find the static stop method on the start class WRAPPER - Clear the exception raised by not finding static stop method inside main class” and “ServiceException” during installation.