R5.2 hotfix10 database PTF13511may fail to apply.

R5.2 hotfix10 database PTF13511may fail to apply.

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Article ID: KB0087650

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Updated On:

Products Versions
TIBCO Object Service Broker for z/OS -
Not Applicable -

Description

Resolution:
Description:
============
During the apply of DB maint for R5.2 hotfix 10, or later when PTF13511 is rolled in, you can get a failure during the apply of PTF13511.
  
Environment:
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o All versions applying DB PTF 13511

Symptoms:
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if you get this problem you will get a failure during the PTF apply and the following in the error log -

Error detected in rule "$FIXYESORNO" at action 1      
Access error on table "@TBL_ACL"                      
GET  @TBL_ACL WHERE OBJECT = @YES_OR_NO & NAME = ALL  
Occurrence not found in table "@TBL_ACL"              

Cause:
======
The cause of this problem is that the rule incorrectly assumes that a security entry for ALL users has been set up for table @YES_OR_NO.
This may not be correct if security has been set up more strictly.

Resolution:
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The resolution for this problem is to create a security entry for table @YES_OR_NO which is for the ALL pseudo group of users, if it doesn't already exist.
You can do this before running the DB maint job.
You can also do this if you have already encountered the problem and rerun the DB maint job with no changes.

If you do not want to have an ALL security entry for this table you can remove it using the security panels after the DB maint is applied.
However if you look at the contents of the table you will probably agree that there is no issue with giving all users view definition and read access to table @YES_OR_NO.

Issue/Introduction

R5.2 hotfix10 database PTF13511may fail to apply.