Products | Versions |
---|---|
TIBCO ActiveMatrix Service Grid | - |
TIBCO BPM Enterprise (formerly TIBCO ActiveMatrix BPM) | - |
TIBCO ActiveMatrix BusinessWorks Service Engine | - |
Description:
Systemnode starts up successfully and then goes back to stopped mode immediately.
Symptoms:
The SystemNode logs shows that the node gets another stop command from
tibcohost immediately after the restart. As seen in exception below (from SystemNode logs), there is a node stop initiated by
tibcohost.
***************************************
com.tibco.amx.hpa.node.Node
- TIBCO-AMX-HPA-014644: Shutdown requested by TibcoHost. mode = normal,
reason = node stop initiated at user request, code = -1
***************************************
This
STOP command can be initiated by Administrator or tibcohost command or
an external agent like Hawk and below mentioned steps helps to figure
out this.
Navigate to
http://localhost:8120/amxadministrator/viewaction.jsp to see if there
was a STOP action created at the same time. If yes, the command came
from Administrator. Since user did not actively stop the node, check if
there are any pending messages in below mentioned ems queue
"com.tibco.amf.admin.deploymentServerQueue.SystemHost:SystemNode". In
this case we noticed one pending message in the above mentioned ems
queue. The status shows "pending" and "delivered" which means the
message is not acknowledged yet.
Cause:
The could happen because of some action (initiated by systemuser)
which failed and became stuck in the systemnode deploymentserver queue. There was a "refresh" action for the SystemNode which failed and the
message was not removed from the EMS queue
"com.tibco.amf.admin.deploymentServerQueue.SystemHost:SystemNode" as it
was not acknowledged. Every time systemnode is started, it is picking
the pending message (refresh action) from the above mentioned
deploymentServerQueue and the systemnode is going back to stopped mode.