Products | Versions |
---|---|
TIBCO BusinessEvents Enterprise Edition | - |
Not Applicable | - |
Resolution:
Description:
===========
Inder Windows, with the 32-bit install of TIBCO BusinessEvents, agent(s) reports error "java.lang.RuntimeException: PutAll resulted in an error" after some time. The Inference Agent, Cache Server stops working or crashed.
Environment:
===========
TIBCO BusinessEvents 5.0.0 (32bit)
All Operating Systems
Symptoms:
=========
Errors in log and/or Agents crash - memory usage grows over the time:
java.lang.RuntimeException: PutAll resulted in an error
at com.tibco.cep.as.kit.map.SpaceMap.putAll(SourceFile:235)
at com.tibco.cep.runtime.service.om.impl.AbstractEntityDao.putAll(AbstractEntityDao.java:161)
at com.tibco.cep.runtime.service.cluster.txn.RtcTransactionManager.modifyConcepts(RtcTransactionManager.java:186)
at com.tibco.cep.runtime.service.cluster.txn.RtcTransactionManager.applyTransactionToCache(RtcTransactionManager.java:316)
at com.tibco.cep.runtime.service.cluster.txn.RtcTransactionManager$TxnTask_Cache.run(RtcTransactionManager.java:488)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at com.tibco.cep.runtime.util.CustomBEManagedThread.run(CustomBEManagedThread.java:23)
Cause:
======
Windows 32-bit BusinessEvents agents crashes/stops processing message once process memory is reached (memory usages grows in 32-bit BusinessEvents version when TIBCO DataGrid used for Cache Provider)
Resolution:
========
In most cases we have observed that installing the 64-bit version of TIBCO BusinessEvents solves this issue.