Products | Versions |
---|---|
TIBCO Enterprise Message Service | - |
Not Applicable | - |
Description:
Symptoms
========
This problem can be seen for all clients upto and including 3.1.2.
A JMS Client application using a FT url to connect to a JMS Server may hang if only one JMS Server is running and the connection between the client and the server is broken. The automatic reconnection is rejected as it is not supported to reconnect to the same JMS Server, but the application does not receive any exception due to the broken connection.
Impact
======
Product Limitation
It is not possible for a JMS Client to automatically reconnect to the same JMS Server. However, in case of failure, the JMS application should have received an exception.
Workaround
==========
Do not provide a Fault-Tolerant url when only one JMS Server is running. Alternatively, the reconnection logic can be handled directly by the application, upon reception of the exception (that will happen if no FT url is used).
Cause
=====
This is a defect of the JMS Client library.
Resolution
==========
Upgrade to TIBCO Enterprise Message Service 4.0 that fixes the problem.
Symptoms:
Cause: