Products | Versions |
---|---|
TIBCO iProcess Objects Server | - |
Not Applicable | - |
Resolution:
Description:
============
High volumes, several per second, of the error:
salq_list_open() failed, qlistsh=0 err=0
are being reported in the TIBCO iProcess Objects Server (iPOS) log, SWDIR\logs\SWEntObjSv01.log
(where SWDIR is the installation directory of the TIBCO iProcess Engine).
Environment:
==========
o All supported platforms.
o All versions of TIBCO iProcess Engine prior to version 11.0.1.6 (Contact TIBCO Support for exceptions).
Symptoms:
=========
Together with the high volume of error messages in the TIBCO iPOS log the actual TIBCO iProcess Objects Server process may fail abnormally.
Cause:
=====
The salq_list_open() failed, qlistsh=0 err=0 errors mean that the TIBCO iPOS is trying to open a workqueue by communicating with the Work Item Server (WISRPC) process. However, the WISRPC does not have the workqueue cached and returns a code to the iPOS causing it to perform an infinite loop that may result in the iPOS process failure.
Resolution:
=========
The issue has been fixed in the TIBCO iProcess Engine from version 11.0.1.6 onwards.
A workaround to the problem is to stop and restart all the TIBCO iProcess Engine processes.