When attempting to install the TIBCO iProcess Engine (iPE) 11.3.0 product on Windows 2008 R2 x64, the iPE installer throws "Unable to open the file: fil.dll rc=-1".The iPE product is unable to be installed due to this error.

When attempting to install the TIBCO iProcess Engine (iPE) 11.3.0 product on Windows 2008 R2 x64, the iPE installer throws "Unable to open the file: fil.dll rc=-1".The iPE product is unable to be installed due to this error.

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Article ID: KB0088117

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Updated On:

Products Versions
TIBCO iProcess Engine (Oracle) -
Not Applicable -

Description

Resolution:
Description
===========
When attempting to install the TIBCO iProcess Engine (iPE) 11.3.0 product on Windows 2008 R2 x64, the iPE installer throws "Unable to open the file: fil.dll rc=-1".  The iPE product is unable to be installed due to this error.

Environment
===========
TIBCO iProcess Engine 11.3.0 for Windows 2008 R2 x64 using the Oracle client 11.2.0.2.

It is likely that the same problem will also occur on the Windows 7 x64/Oracle client 11.2.0.2 combination.

Cause
=====
There are two main causes of the "Unable to open the file: fil.dll rc=-1" error on the Windows 2008 R2 x64/Windows 7 x64 platform.

1). The 64-bit version of the Oracle 11.2.0.2 client is being used rather than the required 32-bit version.

2). The "Oracle Services for Microsoft Transaction Server" aka. ORAMTS option has not been installed into the Oracle client 11.2.0.2 Software Location.

Resolution
==========
Ensure that both of the following conditions are met.

1). Install the 32-bit version of the Oracle 11.2.0.2 client ie. p10098816_112020_WINNT_3of6_DB_Client.zip.

Note that the Oracle 11.2.0.2 32-bit client version is available from the "Patches & Updates" section of the Oracle Support website - "https://support.oracle.com".  It is not available on the regular Oracle downloads site located at "http://www.oracle.com/technetwork/database/enterprise-edition/downloads/index.html".

NOTE: the 64-bit version of the Oracle 11.2.0.2 client is called p10098816_112020_MSWIN-x86-64_4of7.zip.  You do not want that version.

2). Ensure that you installl the "Oracle Services for Microsoft Transaction Server" option as follows:

a).  Use p10098816_112020_WINNT_3of6_DB_Client.zip to install a "Runtime" Oracle client 11.2.0.2 32-bit install into the "C:\app\&ltusername>\product\11.2.0\client_1" Software Location aka. the OracleClient11g_home1.

b).  Run the Oracle 11.2.0.2 client installer again, but this time perform a "Custom" Oracle client 11.2.0.2 install into the same Software Location as above.  Choose "Oracle Services for Microsoft Transaction Server" from the list of options and install it.

c).  Install iPE 11.3.0 as per the Installation Guide.

Issue/Introduction

When attempting to install the TIBCO iProcess Engine (iPE) 11.3.0 product on Windows 2008 R2 x64, the iPE installer throws "Unable to open the file: fil.dll rc=-1".The iPE product is unable to be installed due to this error.