The MFT Agent will stop immediately after startup after upgrading the MFT Server

The MFT Agent will stop immediately after startup after upgrading the MFT Server

book

Article ID: KB0088258

calendar_today

Updated On:

Products Versions
TIBCO Managed File Transfer Agent -
Not Applicable -

Description

Resolution:

Description:

The MFT Agent will stop immediately after starting after the MFT Server has been upgraded from 1.1 to 1.2.

Environment:

TIBCO Managed File Transfer Agent 1.1 and 1.2

Symptoms:

After upgrading the MFT Server from 1.1 to 1.2, the MFT Agents do not start.  The MFT Agent will appear like this:

2009-11-23 19:45:55,554 (ERROR)]  Job-ConfigLoader Failed to process Self Servi
ce request: Invalid request envelope
[2009-11-23 19:45:55,569 (ERROR)]  Job-System com.tibco.ax.tcm.messenger.runtime
.impl.StartupException: [00-30-0318-E] Error occurred while downloading configur
ation from MFT server: Failed to process Self Service request: Invalid request e
nvelope.
        at com.tibco.ax.tcm.messenger.runtime.impl.DataLoader.proceedExecution(D
ataLoader.java:809)
        at com.tibco.ax.fw.runtime.outbound.transport.http.HTTPTransport.send(HT
TPTransport.java:282)
        at com.tibco.ax.fw.runtime.outbound.transport.TransportBase.run(Transpor
tBase.java:47)
        at com.tibco.ax.tcm.messenger.util.TcmClientThreadPool$ManagedThread.run
(TcmClientThreadPool.java:374)

[2009-11-23 19:45:55,569 (ERROR)]  Job-System Fatal exception caught:
+++  [00-30-0301-E] Error occurred while initializing product TIBCO Managed File
Transfer Agent [StartupException]
   +++  Caused by: [00-30-0371-E] Error occurred during bootstrap of product TIB
CO Managed File Transfer Agent. [StartupException]
      +++  Caused by: [00-30-0318-E] Error occurred while downloading configurat
ion from MFT server: Failed to process Self Service request: Invalid request env
elope. [StartupException]

Cause:

The MFT Server configuration was not re-created after the MFT Server upgrade was done.

Resolution:

The error is either due to the bootstrapping agent not being present in the MFT configuration store, or due to the installation not being recreated after the software upgrade.  To resolve:

1.  Make sure that the installation was re-created after the MFT Server was upgraded.  If not, use the standard procedure to recreate the MFT installation, and re-import your previous configuration.

2.  Make sure that the agent is defined in the configuration store.  If it is not, define the agent in the configuration store.

Issue/Introduction

The MFT Agent will stop immediately after startup after upgrading the MFT Server