Products | Versions |
---|---|
TIBCO BusinessConnect | - |
Not Applicable | - |
Resolution:
Description
==========
BusinessConnect 5.3.X appears to be handling inbound transaction multiple times in a multiple engine environment when using the FTP transport.
Environment
===========
TIBCO BusinessConnect 5.X
Cause
==========
The file lock in the shared directory may be allowing multiple FTP pollers to execute on multiple engines. Under normal operation, only one BC engine runs the FTP poller.
Resolution
==========
1). Stop all BC engines, and clear the checkpointing table.
2). Delete the flock as described in SOL1-BVK35L
3). Restart all BC engines.