Products | Versions |
---|---|
TIBCO ActiveMatrix BusinessWorks Plug-in for Oracle E-Business Suite | - |
Not Applicable | - |
Resolution:
Description
=========
If the firewall idle timeout setting closed the connections to the DB server, it takes a long time for TIBCO BusinessWorks Plugin for Oracle E-Business Suite to get the connection successfully to the Oracle server to invoke the procedure call.
The un-expected behavior can be observed in the BW log between the timestamps of 'Start PLSQL API eval(ProcessContext processContext, XiNode inputData) ' and 'Get connection successfully'.
Symptoms:
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After the connections are closed by the firewall during a period of inactivity, when creating a new procedure call the TIBCO BusinessWorks Plugin for Oracle E-Business Suite will find the available connections in the connection pool and will take a long time to successfully get the connection.
Environment
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Oracle E-Business Suite Version 11.5.10.2
Oracle RDBMS version 11.2.0.3.0
Cause
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The Firewall idle timeout setting closed the connections to the Oracle database server, however, TIBCO BusinessWorks Plugin for Oracle E-Business Suite does not detect the connection lost error.
Resolution:
==========
Prevent the firewall idle timeout setting from closing the connections to the Oracle database server for running TIBCO BusinessWorks Plugin for Oracle E-Business Suite.
Option1: Set the Oracle SQLNET.EXPIRE_TIME to a value which should be less than the firewall idle timeout. With such a setting, the Oracle server will kill the idle connection when it meets the SQLNET.EXPIRE_TIME.
Option2: Use a BW process to invoke a call to the database so as to make the connection to the Oracle database active within the period of firewall idle timeout.