Case sensitivity of email addresses in BusinessConnect configuration.

Case sensitivity of email addresses in BusinessConnect configuration.

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Article ID: KB0089071

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:

When using the AS1 transport, the following error occurs:

"Unable to determine Host or Trading Partner for message. Please check Valid Email Address List settings for Host and Trading Partner."

This occurs even when the email addresses appear to be correct in the AS1 configuration.


Symptoms:
Email addresses occasionally do not resolve on inbound and outbound messages.  The transaction fails with the following error:

"Unable to determine Host or Trading Partner for message. Please check Valid Email Address List settings for Host and Trading Partner."

Cause:
The BC AS1 process resolves email address as follows:  The username is case-sensitive while the domain (the value after the ampersand ("@") is case-insensitive.

Issue/Introduction

Case sensitivity of email addresses in BusinessConnect configuration.

Resolution

Make sure to specify the user name with the correct case when configuring the AS1 email addresses.

Additional Information

BusinessConnect Trading Partner Administrator Guide.