Products | Versions |
---|---|
TIBCO BusinessConnect | - |
Not Applicable | - |
Resolution:
Description:
==========
My BC server is crashing during start up and I want to know what libraries/jar files are loaded at the runtime.
Environment:
==========
BusinessConnect all versions
Symptoms:
=========
BC server crashes due to JRE or JDBC or other libraries missing or not being specified in the classpath. The exceptions in the log generally look like the following: "java.lang.NoClassDefFoundError"
Cause:
======
The BC engine crashes on startup when some of the libraries required for BC engine are missing in the class path.
Resolution:
=========
Add “debug” flag in the BC single/interior server command/shell script.
As an example. modify the BusinessConnect-Interior_Server.cmd file to look like this:
"C:/tibco/bc/5.3/bin/bcengine.exe" --debug --run --propFile "C:/tibco/tra/domain/domain_name/application/BusinessConnect/BusinessConnect-Interior_Server.tra"
The console output will show a list of the classpath entries. From this list, you can determine which classes or jars are missing from the classpath.