Why are BWPM client log or NJAMS log entries not seen in the BW application log after adding the NJAMS variables/properties in the bwengine.tra?

Why are BWPM client log or NJAMS log entries not seen in the BW application log after adding the NJAMS variables/properties in the bwengine.tra?

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Article ID: KB0089341

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Updated On:

Products Versions
TIBCO BusinessWorks ProcessMonitor -
Not Applicable -

Description

Description:
No log entries for BWPM are seen in the BW application log after adding the NJAMS variables/properties in the bwengine.tra
Symptoms:
N/A
Cause:
NJAMS log entries are not seen in the bw engine log because the NJAMS variables/properties are not in the application tra file.



Resolution

Once you add the NJAMS variables/properties in the bwengine.tra file you need to re-deploy the BW application. That is when the bwengine.tra is used as a template to generated the BW application tra file. For a quick test, you can apply the NJAMS variables/properties directly on application.tra. The cleaner way to carry over the changes in bwengine.tra is by redeploying the BW application.



Issue/Introduction

Why are BWPM client log or NJAMS log entries not seen in the BW application log after adding the NJAMS variables/properties in the bwengine.tra?