Products | Versions |
---|---|
TIBCO Administrator | - |
Not Applicable | - |
Description:
Sometimes the software version in TIBCO Administrator GUI doesn't update as expected even though a new service pack is installed. For example, TIBCO BusinessEvents 5.1.2 is installed but TIBCO Administrator GUI still shows TIBCO BusinessEvents 5.1.1.
Symptoms:
This issues happens randomly even on the same operating system. No error or exception can be seen in any log file. The right production information can be seen in tsm.log if the option "-tsm_traceLevel" is set to -1 in $TIBCO_TRA_DOMAIN_HOME/domainname/hawkagent.cfg.
Cause:
Hawk agent depends on $TIBCO_HOME/tra/5.X/lib/install/TIBCOInstallerUtility.jar to detected installed components. In TIBCO Runtime Agent version 5.7.4 and lower, all builds of TIBCO products will be detected. For example, all three versions will be detected if the customer installed TIBCO BusinessEvents 5.1.0, 5.1.1 and 5.1.2.
Hawk Agent does not check the maintenance version while synchronizing with POF. It totally depends on which build is detected first. The order may vary on different machines. For instance, if the Hawk agent detects BusinessEvents 5.1.1 before BusinessEvents 5.1.2, BusinessEvents 5.1.2 will not be synchronized to TIBCO Administrator. The user will see BusinessEvents 5.1.1 in TIBCO Administrator GUI instead of BusinessEvents 5.1.2.
This was fixed in TRA 5.8.0. Only the highest build will be detected.