Email notifications fail even though the TIBCO Collaborative Information Manager(CIM) server machine can talk with a SMTP machine and all values appear correctly set in ConfigValues.xml.

Email notifications fail even though the TIBCO Collaborative Information Manager(CIM) server machine can talk with a SMTP machine and all values appear correctly set in ConfigValues.xml.

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Article ID: KB0089439

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Updated On:

Products Versions
TIBCO Collaborative Information Manager -
Not Applicable -

Description

Resolution:
Description:
==========
Email notifications fail even though TIBCO server machine can talk with SMTP machine and all values appear correctly set in ConfigValues.xml.

Environment:
============
TIBCO Collaborative Information Manager  (CIM) 8.0.1.

Symptoms:
=========
Email notifications that should be sent from a running CIM workflow process fail to materialize on the SMTP server.

Cause:
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Beyond a failure of communications at the operating system level between the TIBCO CIM and SMTP servers (Telnet &ltSMTP hostname> &ltport (usually 25>) should demonstrate whether communications between the TIBCO CIM and SMTP servers is alright.  Three factors most likely to cause a failure in communicating between the TIBCO CIM and SMTP servers are:

1). Deletion of System Environment Variables AFTER CIM has started running.

2). http://&lthostname>:&ltport>/eml/Login used as Input URL instead of http://&lthostname>:&ltport>/eml/Home  (Login instead of Home) .

3). email addresses (handles) incorrect (usually caused by mis-typing).

Resolution:
=========
1). Confirm that the following System Enterprise Variables have been defined on the CIM Operations server as System Environment Variables.
NOTE: Exact values will vary - the values below are given for illustrative purposes only.

# java environment variables
JAVA_HOME=C:\Program Files\java\jdk6\jdk
JRE_HOME=%JAVA_HOME%
PATH=%JAVA_HOME%\bin;%PATH%

# JBOSS environment variables
JBOSS_HOME=C:\tibco\jboss\jboss-5.1.0.GA

# oracle environment variables
ORACLE_BASE=C:\oracle\product
ORACLE_HOME=%ORACLE_BASE%\1101
ORACLE_SID=&ltSID>
ORACLE_OWNER=&ltlogin name>
LD_LIBRARY_PATH=%ORACLE_HOME%\lib
NLS_LANG='ENGLISH_UNITED KINGDOM.UTF8'
PATH=%ORACLE_HOME%\bin;%ORACLE_HOME%\bin\OPatch;%ORACLE_HOME%\OPatch;%PATH%
CLASSPATH=%ORACLE_HOME%\jdk\jre;%ORACLE_HOME%\jlib;%ORACLE_HOME%\rdbms\jlib;%ORACLE_HOME%\network\jlib;%CLASSPATH%

# TANGOSOL environment variables
TANGOSOL_HOME=C:\oracle\product\coherence\
MEMBER_ID=&ltUnique Name>

# TIBCO / MQ environment variables
TIBCO_HOME=C:\tibco
NODE_ID=Member1
CIM_HOME=C:\tibco
MQ_HOME=%CIM_HOME%\cim\8.0
MQ_LOG=%MQ_HOME%\log
MQ_COMMON_DIR=%MQ_HOME%\common
MQ_CONFIG_FILE=%MQ_HOME%\config\ConfigValues.xml

2). Confirm that the  Input URL is http://&lthostname>:&ltport>/eml/Home  (ends in Home).

3). Confirm that the given email addresses are correct (including those defined for the users - the recipients - being emailed).

4). If an item in 1, 2 or 3 above required a change, restart the CIM server now.

5). Test out SMTP communication between CIM and SMTP server are working using testEmail.sh / testEmail.bat (found in $MQ_HOME/bin).

6). As a further check, it is advisable to turn on Rulebase Tracing and Workflow Tracing (set in ConfigValues.xml) to check that all workflow activities are executing correctly. Restart the CIM server after setting Rulebase Tracing and Workflow Tracing to true and again, after testing when Rulebase Tracing and Workflow Tracing needs to be set back to false for the sake of server performance

7). If the tests are still unsuccessful, look next at HTML form usage:

   Use Rulebase / Workflow Tracing again together with elink.log to check whether any workflow activity parameters are causing problems for / being rejected by CIM .

Issue/Introduction

Email notifications fail even though the TIBCO Collaborative Information Manager(CIM) server machine can talk with a SMTP machine and all values appear correctly set in ConfigValues.xml.