Error: “Workflow server error.Role Does Not Exist”while routing task in the TIBCO BusinessWorks Collaborator desktop.

Error: “Workflow server error.Role Does Not Exist”while routing task in the TIBCO BusinessWorks Collaborator desktop.

book

Article ID: KB0089447

calendar_today

Updated On:

Products Versions
TIBCO BusinessWorks Collaborator -
Not Applicable -

Description

Description:
Encountering the error, “Workflow server error.Role Does Not Exist” when routing a task to another role. Workflow users roles exist in Admin, IC database and workflow. User sync is successful from Admin. This error occurs while routing tasks.
Symptoms:
In the TIBCO BusinessWorks Collaborator desktop, when routing a task to a different role and IC server, the Repo server runs fine though the Workflow user roles exists in Admin. The IC database and Workflow user sync is successful. This error is seen while routing tasks.
Cause:
Created jobs and users trying to work with old jobs using a new user. While trying to route tasks, the issue occurs in  TIBCO BusinessWorks Collaborator desktop: “Workflow server error- Role Does Not Exist”.

Resolution


Attempting to work with old jobs associated with old users. To verify this, create a new job, users and route tasks using new users. This is expected behavior as old jobs may not get associated with a new user. Create new jobs to work with new users.

Issue/Introduction

Error: “Workflow server error.Role Does Not Exist”while routing task in the TIBCO BusinessWorks Collaborator desktop.