Products | Versions |
---|---|
TIBCO ActiveMatrix BusinessWorks | - |
Not Applicable | - |
Description:
Symptoms
=========
If your BW project is configured to run with the following settings :
-MaxJobs is set to certain value
-the BW project is making use of call process activity
-ActivationLimit is set to false
-blocking activities like Req-Rep, sleep activities are present in the called process,
the above settings may cause jobs to be ‘paged out’ and ‘paged in’ depending on the incoming load. Under these circumstances incorrect data may get passed to the activities and you may see unexpected behaviour and exceptions. This is applicable only to BW 5.3.0, BW 5.3.1, BW 5.3.2 and BW 5.3.3
Impact
======
This may cause loss of data
Workaround
==========
Setting activation limit to true will avoid paging to happen when blocking activities are encountered. This will help the situation.
Cause
=====
At the time of ‘paging in’ a job in a called process, the job object is constructed with incorrect attributes. As a result incorrect data may get passed to the activities.
Resolution
=========
Please apply BW 533 Hotfix 1, which has the fix for this pager issue. BW 533 Hotfix 1 will be available by mid-October 2006
Symptoms:
Cause: