Products | Versions |
---|---|
TIBCO Runtime Agent (TRA) | - |
Not Applicable | - |
Resolution:
Description:
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In Installed Software link, we can not see the expected BW/Adapter software. The customer can not deploy any applications through the Admin GUI because of this. Application services shows disabled.
Environment:
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Unix/Linux OS
Symptoms:
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Customer can not see new version BW/Adapter (e.g. bw 5.9 or above, adapter 6.x) in Admin GUI. And the vpd file seems fine.
After enable the tsm trace, we can see there’s no lock for vpd files and hawk can not detect the installed BW/Adapter.
Cause:
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Possible Cause1:
For BW/Adapter which uses the Universal Installer, Hawk will try to get their installation information in <TIBCO_HOME>/_installInfo folder. When the BW/Adapter XML is corrupted, Hawk can not recognize them.
Possible Cause2:
Customer might set a system environment variable which is called “TIBCO_HOME”. This “TIBCO_HOME” will overwrite the one defined in the hawkagent_<domain_name>.tra file. If this “TIBCO_HOME” points to a wrong location, Hawk will not be able to find the _installInfo folder.
Resolution:
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For the first possibility, can copy the problem XML file to a working-fine environment to see whether it will show up in tsm.log or not. If not, it means that the XML file is corrupted. Re-install the corresponding BW/Adapter software.
For the second possibility, you can use the command “echo $TIBCO_HOME” to check. Run command “unset TIBCO_HOME” to unset the system environment variable. Then restart Hawk.