Error:Cannot get db connection for URL and invalid username/password.

Error:Cannot get db connection for URL and invalid username/password.

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Article ID: KB0090040

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
The BusinessConnect interior server stops working after the BusinessConnect database settings are changed.
Symptoms:
When the BusinessConnect interior server is restarted, the following error is seen in the InteriorServer.log file:


Cannot get db connection for URL and invalid username/password

and the engine eventually stops.



Cause:
The BusinessConnect DB configuration information is embedded in the Interior Server deployment files. If the database URL, username, or password is changed, a new deployment must be generated to update the DB configuration information.

Resolution

1).  Undeploy and delete the current Interior Server(s) configuration.
2).  Generate a new BC deployment. BC should retain most of the configuration settings in the deployment.
3).  Deploy the engines as before.
4).  Restart your configuration.

Issue/Introduction

Error:Cannot get db connection for URL and invalid username/password.

Additional Information

BusinessConnect Interior Server Administration Manual