TIBCO BusinessEvents Agents are stopping abruptly, without any trace in the logs.

TIBCO BusinessEvents Agents are stopping abruptly, without any trace in the logs.

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Article ID: KB0090043

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
============
TIBCO BusinessEvents (BE) Agents are stopping abruptly, without any trace in the logs. The logs does not show any shutdown information.


Environment:
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TIBCO BusinessEvents version 3.x, 4.x, 5.x
TIBCO HAWK
All Operating Systems.

Symptoms:
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The BE engines may be terminated abruptly without any trace in BE logs.

Cause:
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Generally this is due to monitoring agents like TIBCO HAWK, which monitors the running processes and terminates them if a specific condtion in the HAWK rule is satisfied.

Resolution:
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If you are using HAWK Rules to monitor the BE engines, check the HAWK Rulebase to see if there is any condition that it may terminate the running BE engines. Check the HAWK logs and TSM logs for any clues.

Issue/Introduction

TIBCO BusinessEvents Agents are stopping abruptly, without any trace in the logs.