Emails are not sent for CreateWorkitem activities in spite of setting all SMTP properties correctly in ConfigValues.xml

Emails are not sent for CreateWorkitem activities in spite of setting all SMTP properties correctly in ConfigValues.xml

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Article ID: KB0090160

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Updated On:

Products Versions
TIBCO Collaborative Information Manager -
Not Applicable -

Description

Resolution:
Description:
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Emails are not sent for CreateWorkitem activities in spite of setting all SMTP properties correctly in ConfigValues.xml

Environment:
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TIBCO Product name and version: TIBCO Collaborative Information Manager 8.0.1
Operating System(s): All Operating Systems

Symptoms:
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Emails are not sent for CreateWorkitem activities in spite of setting all SMTP properties correctly in ConfigValues.xml

Cause:
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"com.tibco.cim.workflow.workitem.inboxurl" property not set correctly in the ConfigValues.xml


Resolution:
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The solution for this is to set the "com.tibco.cim.workflow.workitem.inboxurl" property to point to http://&lthost>:&ltport>/eml/Home instead of any other URL, say for example, an inbox. Example:

&ltConfValue description="The inbox URL to be included in email notifications.
Example : http://>host:port>/" name="Inbox URL Link" propname="com.tibco.cim.workflow.workitem.inboxurl" sinceVersion="7.0" visibility="Basic">
        &ltConfString default="change_me" value="http://sjohndt:8085/eml/Home"/>
    </ConfValue>

Attachments:
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References:
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Keywords/Tags:
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CreateWorkitem email

Issue/Introduction

Emails are not sent for CreateWorkitem activities in spite of setting all SMTP properties correctly in ConfigValues.xml