Products | Versions |
---|---|
TIBCO Collaborative Information Manager | - |
Not Applicable | - |
Resolution:
Description:
============
Emails are not sent for CreateWorkitem activities in spite of setting all SMTP properties correctly in ConfigValues.xml
Environment:
==========
TIBCO Product name and version: TIBCO Collaborative Information Manager 8.0.1
Operating System(s): All Operating Systems
Symptoms:
========
Emails are not sent for CreateWorkitem activities in spite of setting all SMTP properties correctly in ConfigValues.xml
Cause:
=====
"com.tibco.cim.workflow.workitem.inboxurl" property not set correctly in the ConfigValues.xml
Resolution:
========
The solution for this is to set the "com.tibco.cim.workflow.workitem.inboxurl" property to point to http://<host>:<port>/eml/Home instead of any other URL, say for example, an inbox. Example:
<ConfValue description="The inbox URL to be included in email notifications.
Example : http://>host:port>/" name="Inbox URL Link" propname="com.tibco.cim.workflow.workitem.inboxurl" sinceVersion="7.0" visibility="Basic">
<ConfString default="change_me" value="http://sjohndt:8085/eml/Home"/>
</ConfValue>
Attachments:
==========
N/A
References:
=========
N/A
Keywords/Tags:
=============
CreateWorkitem email