Products | Versions |
---|---|
TIBCO Hawk | - |
Not Applicable | - |
Resolution:
Description:
========
When installing Hawk on Solaris 10, it hangs at:
The InstallShield Wizard is resolving the products in the suite. Please wait...
Environment:
========
Solaris 10
Hawk 4.9
TIBCOUniversalInstaller-sol-x86.bin
Symptoms:
=======
When using the standard installation command:
./TIBCOUniversalInstaller-sol-sparc.bin –console
it hangs at the InstallShield Wizard resolving stage. After adding installation debug, then from the console output the following errors are seen:
(Apr 26, 2013 3:19:53 PM), Install, com.tibco.installer.wizard.action.TIBCOInstallerInit, err, Failed to set the installer details
(Apr 26, 2013 3:19:53 PM), Install, com.installshield.product.wizardbeans.DynamicSuiteInitialize, err, problem loading product information
(Apr 26, 2013 3:19:55 PM), Install, com.installshield.product.wizardbeans.AssemblyCategoryReference, err, java.lang.NullPointerException
java.lang.NullPointerException
at com.installshield.product.service.registry.PureJavaRegistryServiceImpl.initializeLocalPersistedVariables(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
......
From the log file (–is:log), there is no obvious error.
Cause:
=====
Insufficient disk space (100% used) for USER_HOME where the InstallShield file is located.
Resolution:
=======
Assign more available space (more than 12M).
References:
=======
KB: 31388:How to enable debugging for Universal Installer-> Solution-II