Netrics Server cannot be started on some platforms.

Netrics Server cannot be started on some platforms.

book

Article ID: KB0091528

calendar_today

Updated On:

Products Versions
TIBCO Collaborative Information Manager -
Not Applicable -

Description

Resolution:
Description:
============
On some platforms, the Netrics server cannot be started and no exception or error is reported.


Environment:
===========
Red Hat Linux 6.
AIX
TIBCO Collaborative Information Manager 8.x.x


Symptoms:
========
If we run netricsd directly with option "-c console-log" :

     ./netricsd-4.4.2-linux64-ent -p 5051 -c console-log

an error similar to  the following may appear in the log file console-log:

>>>>>
[2013/01/24-15:07:23] SYSTEM/LIBRARY ERROR at line 1568 of function n/a in file svr_main.c:
  Success (0)
ipc_hostname2int returned error

[2013/01/24-15:07:23] FATAL ERROR at line 1801 of function n/a in file svr_main.c:
  NETRICS SERVER EXITING
Program terminated
>>>>


Cause:
=====
This can be caused by a hostname parsing failure.

Resolution:
==========
Check if the hostname and IP address exist in file /etc/hosts. If not, add its IP and hostname in this file and try again. For example:

10.97.49.141    vm-frank-rh55-x64.tibco.com vm-frank-rh55-x64

Issue/Introduction

Netrics Server cannot be started on some platforms.